configuring wireless and captive portal

Home Page Forums Network Management ZeroShell configuring wireless and captive portal

This topic contains 3 replies, has 0 voices, and was last updated by  nrandom 11 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #40688

    nrandom
    Member

    I have posted in the past but did not receive any help. Hopefully, someone out there will have an answer for me.

    We are a small group of teachers helping at an Indian reservation. We have about 20 students who have to stay at home. We want to connect them via wireless to our school intranet.

    So, here is what I was thinking. Remote student connects to linksys access point connected to ETH00. Once authentication takes place they access school network thru ETH01.

    I want remote students to get dhcp ip of 192.xxx.x.x, then go on to school network which is 10.xx.xx.xx. How would I do that?

    I also want to turn on captive portal. I assume that ETH01 should be the captive portal?

    Not being network technical I sure could use some help here. Or, some pointers in the right direction.

    thanks
    noemi

    #45608

    imported_fulvio
    Participant

    You have to activate the Captive Portal in Routed Mode on the interface connected to the wireless access point (ETH00 in your case).
    You must assign to ETH00 an IP of the subnet 192.xxx.x.0 (this IP is the default gateway and dns for the student clients). After that, enable dhe dhcp server for the subnet 192.xxx.x.x and define an IP range of dynamic addresses for the clients. To the ETH01 you must assign an IP of the school’s network (10.x.x.x) and do not forget to assign to ZeroShell the default gateway for the net 10.x.x.x and put the ETH01 in the NAT list.
    Before to activate the Captive Portal you should test if the student clients reach the external network.
    In any case, for more details, you could read the Cristian Colombini’s guide
    available at the URL http://digilander.libero.it/smasherdevourer/schede/linux/zeroshellEN.pdf

    Regards
    Fulvio

    #45609

    nrandom
    Member

    thank you for the reply. I will try this right now.

    BTW, I read that paper but I guess I do not understand it that well.

    thanks again for the reply.

    #45610

    webwarrior
    Member

    Hi,

    Ensure you activate the authentication portal, before you activate the Gateway portal.

    It does not say it like that in the documentation, and one day it will get updated by someone.

    This should get you going.

    Can you connect to the pc at all, via https://192.168.0.75 ?

    #45611

    nrandom
    Member

    Well, I have had some success but still have problems.

    webwarrior: thanks for the hint but already made that mistake :-)..

    Fulvio: not sure about what you meant when you said include in Nat list. Does this mean in router section do an add to destination, then select RIP nat?

    Here is what happened today:

    1. configured zeroshell with ETH00 as 192.xxx.xxx.xx ; ETH01 as 10.xxx.xxx.xx.
    2. Added 10.xxx.xxx.xx to routing table
    3. Radius configured with AP
    4. Enabled DNS
    5. configured DHCP for 192.xxx.xxx.xx
    6. created users
    7. generated certificate
    8. exported certificate
    9. enabled captive portal

    Windows client connected thru AP and authenticated. However, when I opened the browser I receive and error message: Page redirect error

    If I select the ETH00 IP then I get the captive portal login. But it cannot display intranet web page after login.

    Any ideas about what I was doing wrong?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.