Certificate Error When Logging In From Web

Home Page Forums Network Management ZeroShell Certificate Error When Logging In From Web

This topic contains 4 replies, has 0 voices, and was last updated by  redtdi 10 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #41451

    redtdi
    Member

    Hello:

    I am getting a certificate error when I log in to any of my 9 ZeroShell machines. I normally just click ignore and continue but I’d like to know how to fix this problem so that it doesn’t show up.

    How do I fix the certificate error problem permanently? I don’t have much experience with certificates so a step by step guide would be great if anyone has one.

    Thanks,
    Ken

    #47559

    imported_fulvio
    Participant

    The warning related to the certificate during the web login is due to the fact that the certificate x.509 of the CA used to sign the certificate of the captive portal is not trusted by your browsers. To solve the issue you can:

    1) buy host certificates signed by official Certificate Authority. These certificates are automatically recognized by the web browser;

    2) import the X.509 certificate of the CA of Zeroshell on every clients.

    Regards
    Fulvio

    #47560

    redtdi
    Member

    Thanks for the information Fulvio. Can you give me a short description of what I should do in order to import the x.509 certificate into internet explorer? Should I be imported the host or user certificate?

    Thanks,
    Ken

    #47561

    imported_fulvio
    Participant

    A quick procedure to import the x509 certificate of the CA is to click the link CA in the authentication page of the Zeroshell’s web interface.

    Notice you do not need to import host and personal certificates, but just the signing Certification Authority. This makes automatically trusted any certificates signed by it.

    Regards
    Fulvio

    #47562

    redtdi
    Member

    Does the ZeroShell router have to have a correct DNS name, or can it be accessed by the IP address?

    Sorry for all the questions but I seem to be really struggling with something simple! 🙂

    Thanks,
    Ken

    #47563

    prez2k
    Member

    I was able to get the cert installed, but for some reason I can’t seem to find out how to change the setting in the captive portal to point to a name instead of an IP?

    Since that is the case the certificate, no matter what it is will show an error right? since the certs point to hostnames and not IPs?

    Can someone please advise on how to correct?

    Also I found a great blacklist at URLBlacklist…created my own 17meg file of blocked urls but I can’t get it to load in through the web interface (timeout??) and I don’t know how to replace the built in blacklist at start up..

    Booting off of CDROM….so I’d like to have it stored in the DB saved on the hard drive….

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.