Captive Portal Problem – Disk Space

Home Page Forums Network Management ZeroShell Captive Portal Problem – Disk Space

This topic contains 4 replies, has 0 voices, and was last updated by  Pepones 5 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #43605

    Pepones
    Member

    Hi everyone:
    I installed Zeroshell 1.0.beta16. It Worked well until a few days.
    Since then, the following errors have appeared:
    -The captive portal does not show the user information.(name, MAC)
    -The user certifying popup window didn’t work but user
    could still access the internet.

    I’ve been reading in the forum that may be a problem with the space in HD.
    The profile partition have 10 Gb and have an usage of 32%. (Capacity: 9918MB. Used: 2995MB. Free:6923MB)

    If the partition still have free space, Why it doesn’t grow beyond the 3gb?

    How can I free space? What should I do?

    Also during the ZS’s boot process, I get the following error:
    “Error: Creating templock /var/register/system/mrgt/mrtg.conf_l_7732: No space left on device at /usr/local/mrtg-2/bin/mrtg line… “

    Best Regards.

    #52696

    c3wikz
    Member

    Hi,

    I have the same problem.
    Disk is not full.

    Does anyone have solution?

    #52697

    c3wikz
    Member

    Hi,

    I think that i have solved the problem.
    I deleted all entries in accounting part in folder:

    /var/register/system/acct/entries/

    The problem was (i think), not in free space but in number of files in “entries” folder.

    Zeroshell is now working fine for two days.

    P.S.
    You need too delete all files and folders in:

    /var/register/system/cp/Connected
    /var/register/system/cp/Disconnected

    and

    reboot Zeroshell.

    #52698

    Pepones
    Member

    It´s an ext3 partition. The limit for items in the directory is 32000.
    So, I do not think that’s the problem.
    I already tried the solution that you propose. But it’s a matter of time, to fail again.
    I still searching a definivite solution.
    Don’t give up!
    If anyone has an idea, I invite you to participate.
    😉

    #52699

    c3wikz
    Member

    Hi,

    I now that this solution is not permanent and zeroshell will fail again.
    Now it’s working.
    Problem is definitely in accounting part.
    If you find something please post.
    😀

    #52700

    redfive
    Participant

    Why not try with 2.0.RC2 ? As Fulvio said about this release , “In particular, it has been solved a problem that caused the freezing of the Captive Portal under high load. “
    bye

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.