can’t configure ZS as a router & gateway for different s

Home Page Forums Network Management ZeroShell can’t configure ZS as a router & gateway for different s

This topic contains 3 replies, has 0 voices, and was last updated by  lionspy 9 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #42606

    lionspy
    Member

    can’t configure ZS as a router & gateway for different subnets via 1 WAN simultaneously.
    LAN00 Subnet with grey IP’s like 192.168.0.1/24
    LAN01 WAN with static real (white) IP address/30
    i’m using NAT on LAN01
    LAN02 Subnet /29 with real (white) IP’s for IP-telephony.
    my provider can only delegate my subnet /29 only via external IP on LAN01
    in this configuration all packets from subnet on LAN02 NAT’ed with LAN01 external IP
    How can i obtain that packets from LAN00 are NAT’ed with LAN01 external IP and packets from LAN02 are routed without NAT via LAN01?
    any ideas?
    P.S. sorry for my English – i’m from Ukraine…

    #50994

    ppalias
    Member

    Hi! To accomplish this you must configure iptables from the shell and not from the webgui. First remove any interface from NAT at the webgui. Then issue the following commands in “System -> Setup -> Startup/Cron”
    Select “NAT and Virtual Servers” from the drop down list and fill in the field below the following.

    iptables -t nat -A POSTROUTING -o LAN01 -s 192.168.0.0/24 -j MASQUERADE
    #50995

    lionspy
    Member

    Thank you for guide! Will try in evening.

    #50996

    lionspy
    Member

    In the syntax “-o LAN01” means interface name or its IP address? I’m not good with Iptables syntax…

    #50997

    ppalias
    Member

    It’s the name of the output interface, in ZS should be something like ETH00 or ETH01 etc…

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.