Can’t Authenticated via SSH

Home Page Forums Network Management ZeroShell Can’t Authenticated via SSH

This topic contains 6 replies, has 0 voices, and was last updated by  mharris 9 years, 2 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #42346

    mharris
    Member

    I can’t connect via SSH (username: admin).

    The web GUI password is known… no issues with authentication there.

    The following msg appears in the logs after I attempt to authenticate with SSH.

    Section: k2b5kdc

    14:22:20 AS_REQ (7 etypes {18 17 16 23 1 3 2}) 192.168.142.142: ISSUE: authtime 1271092940, etypes {rep=18 tkt=1 ses=18}, admin@OPS.QUANTUM.COM for krbtgt/OPS.QUANTUM.COM@OPS.QUANTUM.COM

    NB: OPS.QUANTUM.COM is not the real host mentioned in the log.

    Any suggestions? 🙂

    #50107

    ppalias
    Member

    Have you enabled SSH from the “System” -> “Setup” -> “SSH” ?
    You also need to enable access from a subnet and/or interface.

    #50108

    mharris
    Member

    Hi,

    Thanks for your reply…

    Everything looks configured correctly in the System – > Setup – > SSH section. Access is open to the service for the network I’m connecting from. I get a password prompt OK, but the password for admin is not accepted. 😐

    bash-3.2# ssh -v admin@10.5.0.69
    OpenSSH_5.2p1, OpenSSL 0.9.8l 5 Nov 2009
    debug1: Reading configuration data /etc/ssh_config
    debug1: Connecting to 10.5.0.69 [10.5.0.69] port 22.
    debug1: Connection established.
    debug1: permanently_set_uid: 0/0
    debug1: identity file /var/root/.ssh/identity type -1
    debug1: identity file /var/root/.ssh/id_rsa type -1
    debug1: identity file /var/root/.ssh/id_dsa type 2
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
    debug1: match: OpenSSH_5.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.2
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host ‘10.5.0.69’ is known and matches the RSA host key.
    debug1: Found key in /var/root/.ssh/known_hosts:5
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Trying private key: /var/root/.ssh/identity
    debug1: Trying private key: /var/root/.ssh/id_rsa
    debug1: Offering public key: /var/root/.ssh/id_dsa
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: keyboard-interactive
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: password
    admin@10.5.0.69‘s password:
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    Permission denied, please try again.
    admin@10.5.0.69‘s password:
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    Permission denied, please try again.
    admin@10.5.0.69‘s password:
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: No more authentication methods to try.
    Permission denied (publickey,password,keyboard-interactive).
    bash-3.2#

    I suspect something in K5 is pooched – just a guess though.

    #50109

    ppalias
    Member

    Check on “Users” section if user admin has his ” Kerberos 5 Authentication” service enabled.

    #50110

    mharris
    Member

    Hi, k5 is enabled for the “admin” user.

    I think something is fundamentally pooched in the k5 setup.

    #50111

    ppalias
    Member

    Last suggestion before reinstalling the ZS is to try another pc and ssh program.

    #50112

    mharris
    Member

    I’ve tried different authentication ssh clients…

    I don’t believe it to be a client issue.

    Will reinstall and report back. 🙂

    #50113

    abahaba
    Member

    Hi colleagues, using zs.
    My suggestion is to check SSH access through firewall from outside (internet) if so, just enable it to accessed only from specific IP addresses or only from LAN.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.