Cannot connect to OpenVPN. I need it to work.

Home Page Forums Network Management ZeroShell Cannot connect to OpenVPN. I need it to work.

This topic contains 1 reply, has 0 voices, and was last updated by  igork 3 years, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #44407

    igork
    Member

    Hello,

    I am trying to configure OpenVPN (Host to VPN). Based on the documentation, there is not much to do. I enabled the server. Downloaded zeroshell.ovpn file and CA.pem file.

    I have two computers that I used with my previous firewall, so all I had to do it just replace files in config folder with new files.

    When I try to connect, it asks me about user name and password and, after that, I have the following:

    Sun Oct 18 08:25:00 2015 OpenVPN 2.3.4 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Aug 7 2014
    Sun Oct 18 08:25:00 2015 library versions: OpenSSL 1.0.1i 6 Aug 2014, LZO 2.05
    Sun Oct 18 08:25:00 2015 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25340
    Sun Oct 18 08:25:00 2015 Need hold release from management interface, waiting…
    Sun Oct 18 08:25:01 2015 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25340
    Sun Oct 18 08:25:01 2015 MANAGEMENT: CMD ‘state on’
    Sun Oct 18 08:25:01 2015 MANAGEMENT: CMD ‘log all on’
    Sun Oct 18 08:25:01 2015 MANAGEMENT: CMD ‘hold off’
    Sun Oct 18 08:25:01 2015 MANAGEMENT: CMD ‘hold release’
    Sun Oct 18 08:25:07 2015 MANAGEMENT: CMD ‘username “Auth” “admin”‘
    Sun Oct 18 08:25:07 2015 MANAGEMENT: CMD ‘password […]’
    Sun Oct 18 08:25:07 2015 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
    Sun Oct 18 08:25:07 2015 Socket Buffers: R=[8192->8192] S=[64512->64512]
    Sun Oct 18 08:25:07 2015 MANAGEMENT: >STATE:1445174707,RESOLVE,,,
    Sun Oct 18 08:25:07 2015 Attempting to establish TCP connection with [AF_INET]x.x.x.x:1194
    Sun Oct 18 08:25:07 2015 MANAGEMENT: >STATE:1445174707,TCP_CONNECT,,,
    Sun Oct 18 08:25:28 2015 TCP: connect to [AF_INET]x.x.x.x:1194 failed, will try again in 5 seconds: Connection timed out (WSAETIMEDOUT)
    Sun Oct 18 08:25:33 2015 MANAGEMENT: >STATE:1445174733,RESOLVE,,,
    Sun Oct 18 08:25:33 2015 MANAGEMENT: >STATE:1445174733,TCP_CONNECT,,,
    Sun Oct 18 08:25:54 2015 TCP: connect to [AF_INET]x.x.x.x:1194 failed, will try again in 5 seconds: Connection timed out (WSAETIMEDOUT)
    Sun Oct 18 08:25:59 2015 MANAGEMENT: >STATE:1445174759,RESOLVE,,,
    Sun Oct 18 08:25:59 2015 MANAGEMENT: >STATE:1445174759,TCP_CONNECT,,,

    And continues with last three lines forever.

    There is nothing else in documentation. I also use it as a router and firewall. I configured firewall to connect to my web server, and I tried the same configuration to point it to my VPN interface, but it did not help. Because my web server works, and I configured rule for OpenVPN port exactly the same way, I am sure the problem is not the rule. But, who knows…..

    I am new to ZeroShell and I really need help. I need VPN to work, or I will not be able to use it. Please help.

    Version of ZeroShell is 3.4.0

    #53919

    redfive
    Participant

    Are you sure that the TCP 1194 is correctly forwarded to ZS ? And what about the ZS’s firewall rules, INPUT ? Also, the logs on ZS’s side, VPN99_H2L ?
    Regards

    #53920

    igork
    Member

    You were right, I had a typo in a rule, and I can connect now.

    Thank you for your reply.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.