BRIDGE00 not taking IP address from the ISP

Home Page Forums Network Management ZeroShell BRIDGE00 not taking IP address from the ISP

This topic contains 0 replies, has 0 voices, and was last updated by  kirikuchris 3 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #44452

    kirikuchris
    Member

    Hi Everybody,
    It’s my first time to use zeroshell and I am amazed of what it can do! but beeing new on it and in Linux in general, I am a bit lost.
    So I followed all instructions on the the website and installed ZeroShell-3.4.0-USB.img.gz on my SD card (I didn’t find any updated image for SD so I assumed that the USB one would work, which it does but I don’t know if it’s OK to keep it).
    Then I configured the ETH00 to face the internal network with 192.168.0.75 and added 10.10.10.0/24 to be used by the DHCP on this interface.
    ETH01 is connected to my ISP and receive dynamic IP from the ISP
    and WLAN00 has DHCP enabled with 192.168.1.0/24 network for wireless clients.
    ETH01 receives the IP from the ISP without issues but when I created the bridge00 and moved ETH00, ETH01 and WLAN00 into the bridge, I lose my internet connection. When I tell to the bridge to get Dynamic from the ISP, it keeps receiving 10.10.10.10 from ETH00 DHCP.
    My questions are:
    Why do we have to configure Bridge00, what is its utility?
    Did I miss something? Why the Bridge can’t communicate with the ISP to receive a public IP?

    Note: As the ISP assign addresses dynamically, my default route is 10.10.10.1 (on ETH00), may be this the reason?

    Thank you in advance for your answers

    #53958

    reaperz
    Member

    Kinda old to answer, but i think you only need to move your internal interfaces to the same bridge. So if ETH00 is your external IP, then move ETH01 and WLAN00 into same bridge.

    Think of bridge as software switch. You don’t have to use it.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.