Boot using serial one zeroshell 3.0.0 on a soekris 6501

Home Page Forums Network Management ZeroShell Boot using serial one zeroshell 3.0.0 on a soekris 6501

This topic contains 4 replies, has 0 voices, and was last updated by  aseques 4 years, 7 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #43892

    aseques
    Member

    I am installing zeroshell on a soekris 6501 using a pendrive. The issue I’m having is that zeroshell only boots when there is the serial console enabled because the kernel selection menu expects the serial connection to be enabled (specifically at 19200)

      I’ve tried setting it to boot using vga (altough the 6501 doesn’t have one)
      I’ve tried setting it to boot using serial 19200
      I’ve tried setting it to boot using serial 38400

    So far the only way to have a proper boot is having the serial console connected on boot at 19200, otherwise the system won’t boot.

    Any news on this?

    #53230

    aseques
    Member

    I had to change de values of conMute so it could boot as expected.
    http://wiki.soekris.info/What_do_all_those_BIOS_settings_do%3F

    #53231

    rsiera
    Member

    Hi,

    I tried ctrl^P and set conMute=Enabled. boot 81 (from USB) and then word GRUB appears, but then nothing moves.

    I’m using ZeroShell-3.0.0-Disk-2GB.img.gz which I unpacked and copied the img with dd for windows to a usb stick.

    I’m using baud 19200 speed.

    Any ideas why this doesn’t work in my setup?

    #53232

    aseques
    Member

    @rsiera wrote:

    Hi,

    I tried ctrl^P and set conMute=Enabled. boot 81 (from USB) and then word GRUB appears, but then nothing moves.

    I’m using ZeroShell-3.0.0-Disk-2GB.img.gz which I unpacked and copied the img with dd for windows to a usb stick.

    I’m using baud 19200 speed.

    Any ideas why this doesn’t work in my setup?

    In my case I changed both ConMute and ConSpeed

    set ConMute=Enabled
    set ConSpeed=38400

    It’s very importat that you disable the hardware flow control in your minicom/serial connection.

    #53233

    rsiera
    Member

    great, thanks, I’ll give it a try and keep you (and everyone searching for Soekris 😉 ) posted

    #53234

    rsiera
    Member

    Ok, it took me a long time to figure out that my DD.EXE for windows didn’t create valid usb images.
    But this tool did: http://rufus.akeo.ie/
    So then everything went according to plan.


    Start Soekris
    Break with ctrl+P
    Execute following commands:
    set ConLock=Disabled
    set ConSpeed=38400
    set ConLock=Enabled
    set ConMute=Enabled
    attach usb with image
    reboot
    Break with ctrl+P
    Execute command
    boot 81
    Wait for 1,5 min and zeroshell is available

    optionally


    Start Soekris
    Break with ctrl+P
    Execute following commands:
    set ConLock=Disabled
    set ConSpeed=38400
    set ConLock=Enabled
    set ConMute=Enabled
    set BootDrive=81 80 F0
    attach usb with image
    reboot
    Wait for 1,5 min and zeroshell is available

    BTW, sometimes the reset button isn’t enough. Sometimes a power cycle is necessary.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.