ath10k missing file

Home Page Forums Network Management Signal a BUG ath10k missing file

This topic contains 1 reply, has 0 voices, and was last updated by  iulyb 2 years ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #44652

    iulyb
    Member
    6.654706] igb 0000:04:00.0: Using MSI-X interrupts. 4 rx queue(s), 4 tx queue(s)
    [ 6.676166] ath10k_pci 0000:05:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
    [ 6.820742] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/cal-pci-0000:05:00.0.bin failed with error -2
    [ 6.821101] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
    [ 6.821117] ath10k_pci 0000:05:00.0: could not fetch firmware file 'ath10k/QCA988X/hw2.0/firmware-5.bin': -2
    [ 6.877074] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
    [ 6.877165] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board.bin failed with error -2
    [ 6.877176] ath10k_pci 0000:05:00.0: failed to fetch board data
    [ 6.877210] ath10k_pci 0000:05:00.0: failed to fetch board file: -2
    [ 6.877273] ath10k_pci 0000:05:00.0: could not probe fw (-2)

    This missing file s however here
    http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/ath10k/QCA988X/hw2.0

    uname -a
    Linux zs.home 4.4.13-ZS #1 SMP Mon Jun 20

    It seems that the new kernel was compiled with a firmware that was not included in distro.

    Update 1: Did more testing and it seems that kernel 4.4.9 has the same issue and kernel 4.1.15 is missing a different file:

    [    6.550481] ath10k_pci 0000:05:00.0: could not fetch board data 'ath10k/QCA988X/hw2.0/board.bin' (-2)
    [ 6.550546] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
    [ 6.550555] ath10k_pci 0000:05:00.0: could not fetch firmware file 'ath10k/QCA988X/hw2.0/firmware-3.bin': -2
    [ 6.550631] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-2.bin failed with error -2
    [ 6.550639] ath10k_pci 0000:05:00.0: could not fetch firmware file 'ath10k/QCA988X/hw2.0/firmware-2.bin': -2

    Update 2: Turns out that the missing file is board.bin. Added that file, applied my own patch for 5G and now I can see the card but just only as a client. Setup works but cannot start the card.
    Update 3: Figured out all missing bits and pieces and described a how to here: https://www.zeroshell.org/forum/viewtopic.php?t=7143

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.