Asterisk installation script messes up ZeroShell

Home Page Forums Network Management ZeroShell Asterisk installation script messes up ZeroShell

This topic contains 0 replies, has 0 voices, and was last updated by  NetSmith 5 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #43708

    NetSmith
    Member

    Have ZeroShell RC2 running.

    Just ran

    1) cd /Database
    2) wget http://www.zeroshell.net/listing/C000-Asterisk-1.4.22.beta11.tar.bz2
    3) tar xvfj C000-Asterisk-1.4.22.beta11.tar.bz2
    4) cd C000
    5) ./install.sh

    This is what happens:

    100%[==========================================================================

    ========================>] 11,127,600 77.07K/s ETA 00:00

    20:09:13 (30.91 KB/s) – `C000-Asterisk-1.4.22.beta11.tar.bz2′ saved

    [11127600/11127600]

    root@zeroshell Database> tar xvfj C000-Asterisk-1.4.22.beta11.tar.bz2
    C000/
    C000/configs/
    C000/configs/common
    C000/dependencies
    C000/install.sh
    C000/tars/
    C000/tars/C000.tar.bz2
    C000/scripts/
    C000/scripts/20restarting
    C000/scripts/30print
    C000/scripts/10updater
    root@zeroshell Database> cd C000
    root@zeroshell C000> ./install.sh
    Reading configuration …
    Checking dependencies …
    Extracting packages …
    Running scripts …
    Starting updater process for the release 2.0.RC2 …
    –> Checking for installed updates:
    [C000] Asterisk PBX
    –> Replacing files …
    –> Patching files …
    –> Running scripts …
    –> Linking executable binaries …
    ./install.sh: scripts/20restarting: /bin/bash: bad interpreter: No such file or

    directory
    ./install.sh: scripts/30print: /bin/bash: bad interpreter: No such file or

    directory

    root@zeroshell C000> uname
    bash: /bin/uname: No such file or directory
    root@zeroshell C000> ls /bin/bash
    bash: /bin/ls: No such file or directory
    root@zeroshell C000> cat
    bash: /bin/cat: No such file or directory
    root@zeroshell C000>

    root@zeroshell bin> echo $PATH
    /usr/local/bin:/usr/local/sbin:/usr/local/ssl/bin:/usr/bin:/bin:/usr/sbin:/sbin

    :/usr/local/bin:/usr/local/bin/:/usr/local/sbin/

    root@zeroshell bin> echo $SHELL
    /root/kerbynet.cgi/scripts/localman

    root@zeroshell bin> date
    bash: /bin/date: No such file or directory

    Any ideas ?

    One of the tars (C000-zaptel.tar.gz) seem to untar over the / folder,
    But /lib is mounted as readonly

    root@zeroshell /> ls -al /lib
    lrwxrwxrwx 1 root root 10 Aug 6 05:25 /lib -> /cdrom/lib

    root@zeroshell firmware> mount
    tmpfs on / type tmpfs (rw)
    proc on /proc type proc (rw)
    /dev/cdrom on /cdrom type iso9660 (ro)
    none on /sys type sysfs (rw)
    devpts on /dev/pts type devpts (rw,gid=4,mode=620)
    shm on /dev/shm type tmpfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/sda3 on /DB type ext4 (rw,noatime)
    /DB/_DB.001 on /Database type none (rw,bind,noatime)

    But unfortunately /dev/cdrom does not exist

    root@zeroshell firmware> ls /dev/cdrom
    ls: /dev/cdrom: No such file or directory
    root@zeroshell firmware>

    #52820

    giancagianca
    Member

    This file is for beta 11. Not work on RC2.

    Bye.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.