Asterisk and Zeroshell, RTP traffic not passed

Home Page Forums Network Management ZeroShell Asterisk and Zeroshell, RTP traffic not passed

This topic contains 3 replies, has 0 voices, and was last updated by  lordalfa 9 years, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41897

    lordalfa
    Member

    Hi.

    I have installed Zershell. I like it for simplicity and yet it can be very daunting for the new user.

    My home setup is simple.

    2x Xeon with Ubuntu 8.04.3 with Asterisk and VMware server

    8 SIP phones on LAN

    3 remote SIP phone (Nokia)

    Zeroshell is installed on a Celeron(P4) machine with 2x 3Com Gigabit LAN cards(ETH01, ETH02). Motherboard has an Intel 10/100 LAN(ETH00) not not used. Wireless LAN card is a Ubuquiti XR4 (600mW)(ETH03)

    I could get the quick and dirty way to work.

    ETH01=WAN (Cable Modem)
    ETH02=LAN
    ETH03=wifi

    BRIDGE00=ETH01+ETH02+ETH03

    I could go into the internet surf. wifi works too.

    Now the port forwards are made at “Virtual Server”. Asterisk server is on 192.168.1.10

    I forwarded UDP 5060, 4569 and 10000 – 20000 to 192.168.1.10 (BRIDGE00 as the input).

    Hard wired phones work. Now I use the Nokia phone and connect from 3.5G to the server it connects. I can make the call. The internal phone rings, but there is no voice transportation. Means it is silent.

    What am I doing wrong?

    It worked when I was using it with a Dlink 855 Extreme.

    Should I just bridge ETH02 and ETH03. Then input from ETH01? Does it work that way? But if it can ring means that the voice should also transport.

    Thanks if there is any solution.

    #48706

    ppalias
    Member

    Is the cable modem doing the pppoe-dhcp-whatever or Zeroshell is supposed to do that? If yes, then bridging the interfaces is ok, but virtual server won’t work as it is a feature of routing, not bridging.
    If no, then you should remove ETH00 from bridging, setup the wan connection to your ISP, setup NAT and virtual server port forwarding and it should be fine then.

    #48707

    kammann
    Member

    @lordalfa wrote:

    But if it can ring means that the voice should also transport.

    Does your mobile operator support SIP at all? Usually in mobile networks the mobile device only gets an private IP address which is firewalled by the mobile operator at the gateway to the internet.
    If this firewall is not aware of (or blocked for) SIP traffic it might very well be the case that the outgoing (on UDP port 5060) SIP invite message reaches your asterisk server, thus the phone rings but there is no “return” path for the RTP traffic.

    Jens

    #48708

    lordalfa
    Member

    ppalias,

    The cable modem is simple. DHCP ethernet port without any PPPoe.

    kammann,

    It worked in the past with Smoothwall. 5960 and RTP traffic was passed. I did put it in the DMZ and it worked.

    Something about the routing.

    ETH00 goes to DHCP cable modem

    ETH01 static IP with DHCP server

    ETH02 is the XR4 card.

    So I BR0=ETH01 and ETH02. Obtain dynamic IP on ETH00.

    port forward 5060 4569 10000-20000 UDP to the Asterisk server. Using Virtual Server tab.

    No dice. RTP traffic did not get pushed through.

    #48709

    ppalias
    Member

    Have you correctly forwarded these ports on the cable modem? Since the cable modem is authenticating and getting the IP from the provider it should forward the ports at the Zeroshell and then Zeroshell to the sip server.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.