Accessing services on forwarded ports from within the LAN

Home Page Forums Network Management Networking Accessing services on forwarded ports from within the LAN

This topic contains 7 replies, has 0 voices, and was last updated by  tytiger 10 years, 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #41762

    tytiger
    Member

    Ok, I have my WAN Ip address assigned to ETH01 and the LAN is on ETH00, on the LAN i have a few servers, FTP mail and web, Ive forwarded the ports to the respective servers and people can access the services from http://myWANip/ but if i try to access the services the same way i just get directed to the zero shells Web interface or for other ports i get connection refused.
    Is there a way to configure zeroshell so that when a LAN client makes a request to the WAN IP on a forwarded port (80 for example), the request is forwarded the real Server same was as it would be for someone on the internet? My old thomson router could do this, if i logged in to its commandline there was a command “natloopback=enabled” And it would do what im trying to describe. 😕

    #48358

    JC
    Member

    Hi, have u set up the https access, under Setup, so that anyone on ur network can access it or just ur ip. If u set it for just ur ip, then that machine will get directed to ZS if not _all_ local address will get redirected to ZS. the default setup for https is [ur subnet from subnet interface: for me subnet 192.168.0.0/24 from interface ETH00] but this is a private network in a home environment. where i work, only my 2 admin machines can access ZS, as i set the ips of my 2 machines on their LAN interface to b granted access, the rest get the web site, email etc.
    I hope this helps, if i was too confusing ask for clarification 😀

    JC

    #48359

    tytiger
    Member

    It made sense, i added a rule under https that said only 192.168.1.6 on ETH00 could acceess the https, this stopped the ZS admin page from commign up on machines other than the one in the rule when i brows to my WAN IP, the connection times out. (PS yes the port is forwarded and works for people outside the network)

    #48360

    JC
    Member

    so now its local access u want to have. have u enabled ur NAT and under DHCP did u put your domain along w/ ur default gateway and DNS server? i had to do that as well to access the webpage from inside, otherwise the users need to put the web servers local ip.

    #48361

    tytiger
    Member

    @jc wrote:

    so now its local access u want to have. have u enabled ur NAT and under DHCP did u put your domain along w/ ur default gateway and DNS server? i had to do that as well to access the webpage from inside, otherwise the users need to put the web servers local ip.

    Yes, but im not sure how you mean, My NAT is on and working at least as far as internet connectivity goes, and under DHCP i did put my local domain in.

    #48362

    JC
    Member

    To get to my web server at work, after setting up NAT on my pppoe and filling in my gateway DNS1[web server], DNS2[ZS machine/gateway] and Domain, all i do is type the FQDN http://www.mywork.ca and i get the home page.

    i also put the web servers local ip as the first dns then the ZS machine as second dns.

    hope this helps, its all i needed to do.

    good luck
    JC

    #48363

    tytiger
    Member

    this didnt work for me, you must have you web server set up in a weird way, does your web server have a DNS server of sorts?

    #48364

    JC
    Member

    yes, it does and is running windows server 2k3

    #48365

    tytiger
    Member

    Ahh that might be why then, mines running Ubuntu linux and doesnt have any DNS software installed. its given me an idea though, thanks.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.