3.9.0 experience – http failures

Home Page Forums Network Management ZeroShell 3.9.0 experience – http failures

This topic contains 7 replies, has 4 voices, and was last updated by  Michael Cyr 3 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #64205

    Michael Cyr
    Participant

    Thanks for Zeroshell! Love having the capability of an enterprise router for my home network!

    This is just a report of my experience upgrading from 3.8.2 to 3.9.0. I am back to 3.8.2 and happy.

    1. The upgrade went smoothly and reboot was accomplished without issue.
    2. I didn’t notice any problems right away but a few hours later started getting failures trying to reach common websites such as http://www.cnn.com. Received errors such as “server took too long to respond” and “connection refused”.
    3. I found that using the https side of the same sites TENDED to work, e.g., https://www.cnn.com
    4. I didn’t think it could be a DNS issue but I set my client to 8.8.8.8 (google DNS) with the same result
    5. I don’t have ANY firewall rules in ZS
    6. I am doing QOS. I did not try turning off QOS.
    7. I verified that the problem was caused by my ZS router by connecting a laptop directly to my DSL modem and was able to reach the same sites.
    8. I also checked that my laptop and other computers do not have any proxy settings.

    Thanks!

    #64271

    Luca B
    Participant

    I had the same http with 3.9 ZS release as reported by Michael and I had to revert beck to 3.8.2. So far I have not found the culprit so still using 3.8 rel. but unable to upgrade again.
    Any idea/suggestion is more than welcome
    Luca

    #64285

    arfon
    Participant

    Having the same problem. Random pages fail to load but reload on a refresh.

    #64290

    Michael Cyr
    Participant

    ok.. i’ve got an idea about this Were either of you folks using Squid? I am.. Going to play with removing it.

    #64293

    Luca B
    Participant

    Thx for your feednack Michael. However I’m not using Squid (pkg 40200) – never installed….

    #64318

    Michael Cyr
    Participant

    My issue with 3.9.0 was resolved by turning off the transparent proxy and virus checking in “Http proxy”. Yes I was also using squid but I think the problem is with the proxy itself. Since the proxy AV only examines http, and cannot examine https, I think it’s of limited use these days anyway. So much is https.

    #64325

    r1vver
    Participant

    can anyone also check https://www.7-zip.org ?
    I have failures to open site from behind ZS 3.9 and ZS 3.7.1
    no proxy and no virus checking enabled, etc
    DNS are also google ones.

    #64326

    Michael Cyr
    Participant

    I’m on 3.9.0, using google DNS, and get there no problem.

    Check that your IP is not blacklisted

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.