2DSLs incoming, weighted/failover routing headaches…

Home Page Forums Network Management Networking 2DSLs incoming, weighted/failover routing headaches…

This topic contains 3 replies, has 0 voices, and was last updated by  arfon 9 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #42109

    arfon
    Participant

    Here’s my situation, I have two incoming DSL connections and I want to set up weighted routing with failover.

    My DSL modems handle the PPPOE so all I need is for ETH01 and ETH02 to get addresses via DHCP.

    I want:
    ETH00 = 192.168.1.1 (static IP (LAN))
    ETH01 = DHCP’d (DSL #1 (WAN))
    ETH02 = DHCP’d (DSL #2(WAN))

    My modems pass the external IP addresses through so I have to DHCP the WAN connections.

    I followed Using ZeroShell as an Internet Gateway and Network Router by Eric Geier and got one DSL line working. I then read Load Balancing and Failover of multiple Internet connections by Fulvio Ricciardi and tried to get it all to work with no success.

    Can anyone give me step-by-step instructions on how to do this????

    #49292

    ppalias
    Member

    I think that if you setup PPPoE on the modem there is nothing like DHCP you should wait on the Zeroshell. My advice is to put the modems in Bridge (RFC1453) and terminate PPPoE on Zeroshell.

    #49293

    arfon
    Participant

    RE: Modems=bridge, ZS doing PPPoE-
    I just tried that… PPP0 and PPP1 come up fine but, when I look in bridge, they aren’t listed as options…

    #49294

    atheling
    Member

    Try looking under “Net Balancer”. You don’t want to bridge the two interfaces (that is something altogether different than “weighted routing with failover”).

    #49295

    arfon
    Participant

    SOLVED!
    The answer was REALLY simple. It was hard to come by due to the fact when you run 1 DSL connection you have to do the bridge thing and the NAT thing….

    Here’s what you do:
    0) Assuming that you already have your local ethernet port working and you are connected to the router with a web browser… AND, you might want to make sure you have a profile active so your changes are saved.

    1) Set up your DSL modems into bridge mode and let Zeroshell do the PPPoE..
    From here on out, configure Zeroshell-
    2) add your PPP connections-
    a) SETUP –> NETWORK–>NEW PPPOE then add DSL connection #1 info.
    b) NEW PPPOE and add DSL connection #2 info.
    3) Check STATUS box. (You might want to make sure that MODE says: LOAD BALANCING AND FAILOVER)
    4) Turn on FAILOVER-
    a) Change IMCP FAILOVER CHECKING to enable
    b) add an EXTERNAL IP address that your machine can ping into one of the FAILOVER IP ADDRESSES boxes.
    5) Hit the SAVE button.

    After this, you should be working.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.