Re: VOIP AND NAT in zeroshell?

#54206

pgbuz
Participant

@iulyb wrote:

Making some generic affirmations will not fix your issue. There are many messages because there are different PBX networking setup. Here are most common:

1) PBX Inetrnet ZS NAT SIP Clients — zhis is what I use, should be no setup / config however you can check conntrack and sip kernel module options. However I found that I need to do a contrack – f command every time I reboot ZS, else some SIP clients will not register.

2) SIP Client Internet ZS NAT PBX . Here u should forward ports or place PBX into a DMZ zone. ZS doesn’t have a DMZ section like a cheap router you will have to create it.

Thank you Iulyb. I didn’t made a specific questions because from the forum I see that a lot of us not super specialists have generical basic problems setting zeroshell for VOIP (I use GUI zeroshell interface). I attach my freepbx peer report with a linksys WRT54GL. You see that the registered external VOIP users have their real pubblic IP: voip communications are OK. I attach the freepbx report with zeroshell where you see that the external registered VOIP users have my private router IP. In zeroshell I putted in NAT both external and internal lan interface and I have port forwarding on RTP and SIP port like in WRT54Gl and I have audio problems. I think that something miss in the BASIC zeroshell setting, something that is automatically solved in linksys WRT54GL with DDWRT v24 VPN generic firmware or other similar routers. How I upload an image here? 😆 [/img]