Re: Binary compatibility ?

#52516

PatrickB
Member

Pffff ! 👿

root@server bin> opkg
bash: /bin/opkg: No such file or directory
😯 ????????

root@server bin> bash -x /bin/opkg
/bin/opkg: /bin/opkg: cannot execute binary file

root@server bin> file /bin/opkg
/bin/opkg: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), corrupted section header size

root@server bin> file /tmp/work/sbin/smbd
/tmp/work/sbin/smbd: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), corrupted section header size

root@server bin> file /bin/true
/bin/true: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.0.0, dynamically linked (uses shared libs), stripped

A priori it would mean that the whole package bank is unusable on this target… Sad news.

Is there someone else in the project with special and reasonable extension wills ? like smbd, wol, logrotate…

Thanks for ideas. Regards.