Reply To: Transparent Proxy DNS error

Home Page Forums Network Management ZeroShell Transparent Proxy DNS error Reply To: Transparent Proxy DNS error

#54231

iulyb
Member

Ok, in my case I have one wireless 192.168.15.XX and i can acess webservers on 192.168.5.xx.

I am using nets fot capture and not IFs.
Here is my setup on https proy:
src:192.168.5.0/24 Capture
src:192.168.5.105 Not Capture
src:192.168.15.0/24 Capture
src:192.168.5.104 Not Capture

5.105 and 5.104 are my TVs and are excluded in order to work with netflix.

Here is my firewall.

Chain Proxy (1 references)
pkts bytes target prot opt in out source destination
169 10140 ACCEPT tcp -- * * 192.168.5.104 0.0.0.0/0
208 12480 ACCEPT tcp -- * * 192.168.5.105 0.0.0.0/0
700 42776 REDIRECT tcp -- * * 192.168.5.0/24 0.0.0.0/0 redir ports 55559
601 33740 REDIRECT tcp -- * * 192.168.15.0/24 0.0.0.0/0 redir ports 55559

ZS get the DNS usually by DHCP from ISP if its own dns server is down. If you run DNS server on ZS then will use itself as resolver (and cache??? ) and it will forward request to whatever forwarder you have under forwarder section. You may need to activate ZS,s dns server and put your server as forwarder
On linux you can also mess with the DNS supplied by DHCP by editing ifcfg-ethxxx script and adding a DNS=xx.xx.xx.xx entry. Unfortunately I don’t see an option to specify your own DNS’s IP and GW for an interface. ZS have this info somewhere under $register dir. I never needed this is, but a few more option on IF setup would be nice. Let me know and if is easy enough I might create a patch.