Reply To: [2.0 RC3] PXE error

Home Page Forums Network Management ZeroShell [2.0 RC3] PXE error Reply To: [2.0 RC3] PXE error

#52847

Hi,

my dhcpd.conf is:

root@labtest tftpboot> cat /tmp/dhcpd.conf
authoritative;
ddns-update-style interim;
ignore client-updates;
option space ipxe;
option ipxe-encap-opts code 175 = encapsulate ipxe;
option ipxe.priority code 1 = signed integer 8;
option ipxe.keep-san code 8 = unsigned integer 8;
option ipxe.skip-san-boot code 9 = unsigned integer 8;
option ipxe.syslogs code 85 = string;
option ipxe.cert code 91 = string;
option ipxe.privkey code 92 = string;
option ipxe.crosscert code 93 = string;
option ipxe.no-pxedhcp code 176 = unsigned integer 8;
option ipxe.bus-id code 177 = string;
option ipxe.bios-drive code 189 = unsigned integer 8;
option ipxe.username code 190 = string;
option ipxe.password code 191 = string;
option ipxe.reverse-username code 192 = string;
option ipxe.reverse-password code 193 = string;
option ipxe.version code 235 = string;
option iscsi-initiator-iqn code 203 = string;
# Feature indicators
option ipxe.pxeext code 16 = unsigned integer 8;
option ipxe.iscsi code 17 = unsigned integer 8;
option ipxe.aoe code 18 = unsigned integer 8;
option ipxe.http code 19 = unsigned integer 8;
option ipxe.https code 20 = unsigned integer 8;
option ipxe.tftp code 21 = unsigned integer 8;
option ipxe.ftp code 22 = unsigned integer 8;
option ipxe.dns code 23 = unsigned integer 8;
option ipxe.bzimage code 24 = unsigned integer 8;
option ipxe.multiboot code 25 = unsigned integer 8;
option ipxe.slam code 26 = unsigned integer 8;
option ipxe.srp code 27 = unsigned integer 8;
option ipxe.nbi code 32 = unsigned integer 8;
option ipxe.pxe code 33 = unsigned integer 8;
option ipxe.elf code 34 = unsigned integer 8;
option ipxe.comboot code 35 = unsigned integer 8;
option ipxe.efi code 36 = unsigned integer 8;
option ipxe.fcoe code 37 = unsigned integer 8;

#host SmartOS {
# hardware ethernet 00:e0:81:5d:c2:5e;
# fixed-address 192.168.4.40;
# next-server 192.168.4.75;
# if exists user-class and option user-class = "iPXE" {
# filename = "smartos.ipxe";
# } else {
# filename = "undionly.kpxe";
# }
#}
subnet 192.168.4.0 netmask 255.255.255.0 {
option routers 192.168.4.75;
option subnet-mask 255.255.255.0;
option domain-name-servers 192.168.4.75, 8.8.8.8, 8.8.4.4;
next-server 192.168.4.75;
if exists user-class and option user-class = "iPXE" {
filename = "smartos.ipxe";
} else {
filename = "undionly.kpxe";
}

default-lease-time 28800;
max-lease-time 28800;
range 192.168.4.20 192.168.4.30;
host 3232236554_00237DFDB8F1 {
hardware ethernet 00:23:7D:FD:B8:F1;
fixed-address 192.168.4.10;


}
host 3232236566_00237DFDB936 {
hardware ethernet 00:23:7D:FD:B9:36;
fixed-address 192.168.4.22;


}
host 3232236594_08002766168D {
hardware ethernet 08:00:27:66:16:8D;
fixed-address 192.168.4.50;


}
}

but I have just one IP range and if I add a new range all is still working.

So can be related to undionly.kpxe binary ?

I use undionly.kpxe dowloaded from http://boot.ipxe.org/undionly.kpxe [iPXE 1.0.0+ (5520)] but is working also undionly.kpxe from http://cuddletech.com/IPXE-100612_undionly.kpxe [iPXE 1.0.0+ (a712)] as suggested by Ben Rockwood [ http://wiki.smartos.org/display/DOC/PXE+Booting+SmartOS ]

As last resouces you can test if something change if you add “Speeding up DHCP”

[http://ipxe.org/howto/dhcpd ]
The PXE specification requires iPXE to wait for replies from a ProxyDHCP server before booting. If you are not using a ProxyDHCP server, then this creates an unnecessary delay of several seconds. You can eliminate this delay using:

option ipxe.no-pxedhcp 1;

(Do not do this if you are using a ProxyDHCP server; it will cause iPXE to ignore whatever the ProxyDHCP server sends!)

Let me know …

see you 😉