Reply To: Zeroshell CaptivePortal not working

Home Page Forums Network Management ZeroShell Zeroshell CaptivePortal not working Reply To: Zeroshell CaptivePortal not working

#52716

ik.omoruyi
Member

There are solutions out there for this.
Here is my solution:

Login as admin

goto Router –> NAT

On the NAT popup page, move ETH00 and ETH01 from Available Interfaces to NAT Enabled Interfaces, then save it and close it.

goto DHCP and click on the New button and create a network on the New DHCP Subnet definition window that pops up(select ETH01).
After creating the network, with the network now showing in the subnet, In the Dynamic IP Configuration section, select the IP range you want, click save in the main DHCP window, Active on: NONE should change to Active on: ETH01.

goto Captive Portal, on the Interface dropdown menu, select ETH01, enable the Active on: checkbox and save. After saving the status should become Active on: ETH01.

Now anybody connected to ETH01 port should get a dhcp address from what you specified earlier on and when trying to do anything will prompted with a login screen. Hopefully, you’ve set up users already.