Reply To: Host-to-site route add problem?

Home Page Forums Network Management VPN Host-to-site route add problem? Reply To: Host-to-site route add problem?

#51241

mattschedler
Participant

Looks like I may have an answer. Basically I tried 3 different versions of the windoze client. One from openvpn.se (linked from the howto on ZS page) and two clients (“Access server” and “Community”) from openvpn.net. Did this:

Installed version from openvpn.se and all worked as it should and routes set up fine. Disconnect worked fine as well (didn’t strip out my default gw). Uninstalled and removed tap device.

Installed community version from openvpn. net… got crazy route additions and disconnect stripped out my default gateway. (route addresses were much more similar to dnsadmin, btw). Uninstalled and removed tap device.

Installed “Access Server” version from openvpn.net… got crazy routes (slightly different then previously) and gw was stripped. Uninstalled and removed device.

Installed openvpn.se community version again… ran perfectly as before. Routes normal and gateway was not stripped.

Also, both openvpn.net versions did not set up the correct routes either so no connectivity to remote network. I noticed that both showed tap driver versions to be 9.x (9.11 and 9.13 I think) while the version that worked had version 8.01 (?).

I think it’s safe to conclude that there is an issue with the version of the client network device driver. Removing whatever version of openvpn.net you have and getting the version from openvpn.se seems to be the ticket.

Link: http://openvpn.se/download.html