Reply To: Problems with CF preparing for ZS

Home Page Forums Network Management ZeroShell Problems with CF preparing for ZS Reply To: Problems with CF preparing for ZS

#51027

xtacy
Member

At last!
The key is CF need to b not partitioned at all just like HDD. But that is the thing which i couldnt do for a long time. Every time i boot linux CF mounts as hdc1(ZS) or sdb1(slax). But with no partitions it would b just hdc or sdb without any digit.
I had a problem with unpartitioning my CF. But somehow under ZS booted from CD and with help of fdisk/cfdisk (4 weird ghost partitions was deleted) i get ability to deletethe main partition but in WinXP! Or i just dont know how2 do it in linux cause fdisk/cfdisk was unable to do it. And i did it in WinXP with admin tools. After that i boot ZS from CD again and my CF was seen by fdisk -l like /dev/hdc (not hdc1 like it was b4) and i did gunzip -c ZeroShell-1.0.beta13-CompactFlash-IDE-USB-SATA-1GB.img.gz>/dev/hdc from usb-stick and tada! it works now!

And the same with HDD – before boot any live linux and doing anything like dd or gupzip>/dev/hdd you must kill all the partitions on this HDD. But with HDDs its much easier 2do. Even with admin tools in WinXP or with any partitioning soft.

Yes, linux is free but it takes a lot of your time…

PS when i got stuck i tried physdiskwrite under WinXP and it didnt help. I choose correct usb drive for it but got no changes on CF. It was just damn waste of my time. And any other win programs that acts like linux’s dd (flashnul, dd tool) also didnt help. And linux methods like dd 2 dev or gunzip 2 dev also. now i know why.

thanx for replies!!!