Reply To: openvpn default gateway not through the vpn

Home Page Forums Network Management ZeroShell openvpn default gateway not through the vpn Reply To: openvpn default gateway not through the vpn

#49243
ppalias
Member
root@zeroshell root> ps auxw | grep vpn
root 10399 0.1 2.4 6704 4628 ? S Dec08 2:31 vpn --dev-type tap --dev VPN99 --mode server --tls-server --proto tcp-server --port 1194 --dh /etc/ssl/dh.pem --ca /var/register/system/openvpn/Auth/X509/CAFile --cert /var/register/system/openvpn/TLS/cert.pem --key /var/register/system/openvpn/TLS/key.pem --daemon VPN99_H2L --ifconfig-pool 10.14.149.178 10.14.149.190 255.255.255.240 --push route-gateway 10.14.149.177 --push --push dhcp-option DNS 10.14.149.1 --push route remote_host 255.255.255.255 net_gateway 1 --push route 10.14.149.176 255.255.255.240 --client-connect /root/kerbynet.cgi/scripts/ov_connect --client-disconnect /root/kerbynet.cgi/scripts/ov_disconnect --mute 3 --management 127.0.0.1 34099 --keepalive 5 60 --duplicate-cn

This is my server side openvpn configuration taken from the shell. It doesn’t send any specific routes, but the DNS and the gateway. On my client file I inject the routes I wish my client to route through the tunnel. Hope this helps, if not please take a screenshot of the web interface page of the vpn configuration so we can take a look.