Reply To: ZeroShell as VPN Client to replace openVPN GUI on XP (Help)

Home Page Forums Network Management Networking ZeroShell as VPN Client to replace openVPN GUI on XP (Help) Reply To: ZeroShell as VPN Client to replace openVPN GUI on XP (Help)

#48538

Andy22
Member

Its still not working, first of all there is no interface “TUN0” in the “TARGET GATEWAY” field under balancing rules.

I tryed to add a new gateway under “Manage” but here again what ip i have to use? I tryed “10.88.0.1” “10.88.0.125” “10.88.0.126” “10.88.0.0”?

In the balancing rule do i just have to fill in “Source IP (*)” -> “192.168.0.100” and leave all other free and just choose the gateway?

It looks like this than with the manually added tun0 gateway.
“MARK all opt — in * out * 192.168.0.100 -> 0.0.0.0/0 MARK set 0x65 tun0 (10.88.0.1)”

Also does it matter if the “Status” on the first page left-top at “NET BALANCER” is enabled/disabled? Aka does the balancing rule apply if it is disabled or is this “Status” just for teh gateways?

Thats the routing after i started openVPN

root@zeroshell root> route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.88.0.1 10.88.0.125 255.255.255.255 UGH 0 0 0 tun0
208.85.2.66 88.76.32.1 255.255.255.255 UGH 0 0 0 ppp0
88.76.32.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
10.88.0.125 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 ETH00
192.168.250.0 0.0.0.0 255.255.255.0 U 0 0 0 VPN99
0.0.0.0 10.88.0.125 128.0.0.0 UG 0 0 0 tun0
128.0.0.0 10.88.0.125 128.0.0.0 UG 0 0 0 tun0
0.0.0.0 88.76.32.1 0.0.0.0 UG 0 0 0 ppp0

That is what i see if i trace a route from the ZS machine directly after openvpn is started:

tracepath www.google.com
1: 10.88.0.126 (10.88.0.126) 1.105ms pmtu 1500
1: 10.88.0.1 (10.88.0.1) 105.492ms
2: 208-85-2-65.turnkeyinternet.net (208.85.2.65) 105.621ms
3: c6509-ny1-i0ge2.turnkeyinternet.net (64.128.116.9) 105.589ms
4: jm20-ny1-ge-0-1-0.turnkeyinternet.net (64.128.116.1) asymm 5 105.233ms
5: turnkey-ge-rtr1.alb.twtelcom.net (66.195.77.149) asymm 6 106.561ms
6: 66.192.243.234 (66.192.243.234) asymm 8 114.665ms
7: no reply

Thats what xp sees after i started openvpn:


tracert www.google.com
Tracing route to www.l.google.com [66.102.1.104]
over a maximum of 30 hops:
1 1 ms 1 ms 1 ms 192.168.0.1
2

This is how the xp machine looks BEFORE and AFTER i start openvpn:


C:Documents and SettingsAdministrator>route print
===========================================================================
Interface List
0x1 ......... MS TCP Loopback interface
0x3 ......... TAP-Win32 Adapter V9 - cFosSpeed Miniport
0x50002 ..... Realtek PCIe GBE Family Controller
===========================================================================
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.0.1 192.168.0.100 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.0.0 255.255.255.0 192.168.0.100 192.168.0.100 20
192.168.0.100 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.0.255 255.255.255.255 192.168.0.100 192.168.0.100 20
224.0.0.0 240.0.0.0 192.168.0.100 192.168.0.100 20
255.255.255.255 255.255.255.255 192.168.0.100 192.168.0.100 1
255.255.255.255 255.255.255.255 192.168.0.100 3 1
Default Gateway: 192.168.0.1
===========================================================================
Persistent Routes:
None

AFTER i stop openvpn it looks like this:

root@zeroshell root> route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
208.85.2.66 88.76.32.1 255.255.255.255 UGH 0 0 0 ppp0
88.76.32.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 ETH00
192.168.250.0 0.0.0.0 255.255.255.0 U 0 0 0 VPN99
0.0.0.0 0.0.0.0 0.0.0.0 U 1 0 0 ppp0

Again im thankful for any advice tip/hint!

PS: I also tryed to enable and disable the default route option in the ppp0 interface, but that openvpn complains that it cant redirect a valid default route. “NOTE: unable to redirect default gateway — Cannot read current default gateway from system”